Tagged: beta Toggle Comment Threads | Keyboard Shortcuts

  • Dan 3:16 am on April 19, 2012 Permalink |
    Tags: , beta   

    It’s time for the 2.1 beta! There’s some totally radical stuff in this release:

    • Autosave timer while editing posts. Every 60 seconds the post will be autosaved.
    • Edit comments! You can edit comments while on the go now.
    • You can now set the width for linked images.
    • All new WordPress.com reader. Navigating posts is much faster and you can add comments to posts that you are reading. You can also share the post to other Android apps!
    • Small improvements to the UI, most notably that the delete post button has been moved to a less prominent spot to prevent accidental taps on it.
    • Reliability improvements
    • Translation updates

    You should test this! The more devices we can test on, the better. Some things to try:

    • Edit a comment, did it save as expected?
    • Write a post and make sure it autosaves every 60 seconds.
    • If you have a WordPress.com blog, try out the new reader (tap ‘Read’ from the Dashboard).
    • Try the new linked media settings, does it link to the image at the scale you set?

    Please leave any feedback here! Even if it works fine, it’d be great to know which device you tested on.

    The app still requires Android 2.1 (eclair) as a minimum. Download the beta here or scan the QR code:

    qrcode

     
  • Dan 5:20 am on January 30, 2012 Permalink |
    Tags: , beta   

    Here’s beta 2 of v2.0.5, it includes a fix for an issue reported last week where content would disappear from the post editor if the device ran low on memory. Make sure to try out the post editor thoroughly.

    Download: http://bit.ly/yyu5qu

    qrcode

     
  • Dan 1:10 pm on January 10, 2012 Permalink |
    Tags: 2.0.4, beta   

    The bugs keep coming, so we keep squashing! Here’s a beta of 2.0.4 that includes the following:

    • Fix for links going out to the end of a paragraph upon upload.
    • Fix for the more tag issue when saving local drafts repeatedly.
    • Underlining text now uses a different class, so users shouldn’t get underlined text where they didn’t it
    • Updated Danish and Bosnian translations

    Give it a go, especially mess around with the more tag. Post here if you see any issues!

    http://bit.ly/AERe6G
    qrcode

     
    • Bill 9:52 pm on January 10, 2012 Permalink | Log in to Reply

      I got a new smart phone a few weeks ago, the Samsung Galaxy Nexus, with Android 4. And I don’t think I have received any notifications about new comments on the new phone, but I got them on the old original Droid. Is the app compatible with Android 4?

      • Bill 10:11 pm on January 10, 2012 Permalink | Log in to Reply

        And, yes, I have had the app on the new phone since I got it. And, fyi, I just installed v. 2.0.4

      • Dan 12:54 am on January 11, 2012 Permalink | Log in to Reply

        Did you turn comment notifications on? You turn them on by tapping the menu button -< Preferences on the main dashboard, then check the box next to the blog you want notifications for and save. Works fine on my Galaxy Nexus.

        • Bill 1:29 pm on January 12, 2012 Permalink | Log in to Reply

          Thanks Dan. I didn’t notice that menu button at the bottom. I was looking at the top menu button and under that looking at Settings and couldn’t find anything about notifications. Thanks! A suggestion… combine Settings and Preferences in one place.

    • superdry 12:19 am on January 12, 2012 Permalink | Log in to Reply

      thanks very much, i need it for my girl

    • Mark Thomas Gazel 11:32 am on January 12, 2012 Permalink | Log in to Reply

      Danish translation works like a charm.

    • Mark Thomas Gazel 12:46 am on January 14, 2012 Permalink | Log in to Reply

      Could you please update the danish translation again. I changed a few, but important, strings.

    • Muz 9:47 pm on January 18, 2012 Permalink | Log in to Reply

      Hi Dan, again thanks for the updates, I really like that the bold and italics are more accessible now. However, I have found that I can no longer access my comments as it results in a force close (I could access it before the 2.0.4 update). I can do a general refresh and the number of new comments does appear over the comments icon, but I cannot access it. I have tried uninstalling, rebooting the phone and then doing a fresh reinstall of the app, but the problem remains. My phone stats remain Sony Ericsson Xperia X10 mini pro, android 2.2.

      • Dan 1:41 am on January 19, 2012 Permalink | Log in to Reply

        Hmm, that’s not good. I don’t see any crash reports that have to do with comments. Can you share your blog’s URL?

    • bsliblog 11:20 pm on November 20, 2012 Permalink | Log in to Reply

      Yeh man, stay tuned for more posts.

  • Dan 8:28 am on December 30, 2011 Permalink |
    Tags: beta   

    2.0.2 is ready for testing, it has the following changes:

    • Fix for self-hosted stats not matching up correctly to WordPress.com
    • Editor fixes
    • Fix for hardware keyboards on some devices
    • Reliability improvements

    Test it out if you’d like! It would be most helpful if you’d try out the editor, play with the formatting buttons and make sure they work as expected.

    http://bit.ly/ttZAmE

    qrcode

     
  • Dan 10:07 am on December 5, 2011 Permalink |
    Tags: beta,   

    Thanks to all for the feedback on Beta 2. Lots of bugs were taken care of last week, especially the bug that deleted the post content after adding an image. So, Beta 3 this week! This should be considered a release candidate, so if you see anything strange be sure to post here about it. @chippy, the Dashboard should look better on your Galaxy Tab now, take a look please.

    Try out Beta 3:

    http://bit.ly/v3xX52
    qrcode

     
    • TheTechChat (@TheTechChat) 11:49 am on December 5, 2011 Permalink | Log in to Reply

      Great, thanks! Only thing is, this one still says Beta 2 in “About…”

      • Dan 11:55 am on December 5, 2011 Permalink | Log in to Reply

        It’s labeled “2.0 Beta”, a bit confusing but a good reminder to remove the ‘Beta’ for the release.

    • Gino 2:19 pm on December 9, 2011 Permalink | Log in to Reply

      @chippy I get a force closed when trying to share a website from the browser. When editing a post, the done button does not work, I have to hit the back button. When trying to post a link, the symbols are stripped from the html code.

    • Lars 3:28 am on December 10, 2011 Permalink | Log in to Reply

      hi dan,

      look at this post lars-mueller.mobi/2011/12/10/frauenfussball-duisburg-gegen-frankfurt-im-dfb-tv/

      under an picture I have an “obj” label.. I this correct?

      greets lars

      • Dan 12:31 am on December 12, 2011 Permalink | Log in to Reply

        Nope, that shouldn’t be there. Thanks for the report.

      • Dan 12:55 am on December 13, 2011 Permalink | Log in to Reply

        If you download the build again, this issue should be resolved.

      • Bret 7:04 am on December 22, 2011 Permalink | Log in to Reply

        I have similar problems to Gino. Instant crash when trying to Share from browser. Can’t move past entry field without hitting back button. I’m on a Samsung Galaxy S2 Epic Touch 4G with Android 2.3.6. Version 1.5 of WP for Android worked like a charm.

        • Bret 7:05 am on December 22, 2011 Permalink | Log in to Reply

          I’ve also installed 2.01 today and the problems persist but the Share post crash is intermittent rather than every time.

    • Lars 4:40 pm on December 11, 2011 Permalink | Log in to Reply

      courios, I have installed the beta 3. and I have 2 Blogs.
      at the first blog, when I wrote an article the more Tag shows in the
      1st blog like this and this works.
      at the second blog, http://androidblogger.eu when I use the more Tag in an HTML Editor the Tag shows. this ……..More I won’t work. The Blogs runs with wordpress 3.2.1 german

      thanks Lars

      • Dan 12:31 am on December 12, 2011 Permalink | Log in to Reply

        Hmm, I tried changing my blog and the app to German but can’t reproduce the issue.

        • Lars 1:15 am on December 12, 2011 Permalink | Log in to Reply

          for myself I have try to change the language to english, but nothing changed. I think I must reinstall my Blog

    • gio_n_s 11:34 am on December 17, 2011 Permalink | Log in to Reply

      hi i translated everything on translate.wordpress.org but when i use georgian language some strings are still in english 😦 whats wrong?

      • Dan 11:41 am on December 17, 2011 Permalink | Log in to Reply

        Not sure, I’ll double check the translation file. What are the strings you noticed that aren’t translated?

    • Gregory Schultz 6:56 pm on December 18, 2011 Permalink | Log in to Reply

      I’m not sure if anyone reported this but I used the ‘Quick photo’ and when I check the post on my blog, it adds [obj] to the post, even if you use the_excerpt.

    • Lars 5:34 am on December 19, 2011 Permalink | Log in to Reply

      hi dan,

      Why sometimes when i write an Articel and include the More Tag it looks like this “……..More”, but when i write an short Articel at my Blog works fine and the more Tag looks like this “

      And when i include an Picture under the Pic is an [obj] symbol.

      Thanks for help an greets from Germany

      Lars

  • Dan 10:58 am on November 24, 2011 Permalink |
    Tags: beta,   

    The WordPress for Android 2.0 Beta 2 is ready! Thanks to everyone that helped test the first beta, a lof of the bugs have been squashed and a few new tweaks have been added. Here’s what’s new:

    • Lots of fixed issues
    • New layouts for the Kindle Fire! Try it out if you’re an early adopter of the device.
    • Link helper doesn’t require selecting text anymore.
    • Editor/Format Bar improvements
    • Updated Swedish, Tamil, Bosnian, Georgian, Turkish, Hungarian, Croatian and Indonesian translations. If you can help translate to your language, check out the GlotPress project at http://translate.wordpress.org to get started.

    Download Beta 2 here:

    http://bit.ly/v3xX52
    qrcode

     
    • Lars 11:30 am on November 24, 2011 Permalink | Log in to Reply

      Great!

      Thanks, Stats works and at the first view i can´t the bugs..

    • Lars 6:59 am on November 25, 2011 Permalink | Log in to Reply

      Sorry ,

      When I edit an existing Post that creates duplicate Content.

    • Josh Williams 10:18 am on November 26, 2011 Permalink | Log in to Reply

      I’m trying to get involved in the open source project, but after checking out I have a bunch of errors. Can anyone shed some light as to what should be in the build path? I have a feeling I am missing something (or multiple things).

      • Dan 11:12 am on November 26, 2011 Permalink | Log in to Reply

        Sure, what are the build errors? Here’s what I’ve got in my build path:

        screen

        • Jonez 6:16 am on December 3, 2011 Permalink | Log in to Reply

          Is that Eclipse? If so, I can help you with programming then. It is the same tool I use at high school.

    • Josh Williams 10:19 am on November 27, 2011 Permalink | Log in to Reply

      Ahh thanks, I had an Android 4.0 target. After setting to 3.0, deleting R.java and regenerating, it works fine. Although the emulator is horribly slow (worse than 2.2 / 2.3.3 emulators). I guess a perfect Christmas present would be a tablet now :>

    • gio_n_s 1:45 pm on November 28, 2011 Permalink | Log in to Reply

      hei thanks for adding georgian 🙂 works fine.
      and i also updated translations

    • chippy 10:04 am on November 29, 2011 Permalink | Log in to Reply

      I’ve found a bug with adding an image. It deletes text below the image.
      I just uploaded a video to demo this – https://www.youtube.com/watch?v=PdW8Y8lXFug
      it also occurs on 3.2 (acer iconia tab a500)

      • Dan 10:16 am on November 29, 2011 Permalink | Log in to Reply

        That’s a good one. The app also looks goofy on your device, there’s no text under the dashboard buttons.

  • Dan 6:41 am on November 13, 2011 Permalink |
    Tags: beta,   

    It’s time for the 2.0 beta! The new version has a new UI and a ton of great new features! Your help in testing it out before we release to Android Market is greatly appreciated.

    If you’d like to help test, simply hit the link below or scan the QR code to install the new version. You will need a device with Android 2.1 or newer and ‘Unknown Sources’ enabled in Settings & Applications. Some things to test for:

    • Are all of your blogs still in the app if you upgraded?
    • Edit your blog’s settings
    • Create a new post, add some rich text, media attachments and try tapping on an image to set its title and caption. Also try scheduling a post and setting its post format.
    • Try to post a quick photo/and or quick video.
    • Edit an existing post on your blog.
    • Create and/or edit a page.
    • Enable comment notifications (Menu Key->Preferences at the dashboard view). Do new comment notifications work as expected?
    • Try the new reader! Change filters, like some posts, view freshly pressed, etc.
    • View your stats.
    • From comments/posts/pages/stats view, change to a different blog by tapping the blog name in the action bar.

    Mainly, please try out all of the new features and try to break it 🙂 If nasty things happen or if you have any feedback, please reply here! It usually helps to know which device and android version you are running.

    http://bit.ly/v3xX52
    qrcode

     
    • Heather 8:02 am on November 13, 2011 Permalink | Log in to Reply

      Droid X — app force closes when trying to view any stats other than the number of overall views. Can’t access post/page views, referrers, clicks, or search terms.

    • Mark 9:10 am on November 13, 2011 Permalink | Log in to Reply

      Force closes when trying to attach a photo from the gallery. Running on an Asus Transformer.

    • Lars 10:23 am on November 13, 2011 Permalink | Log in to Reply

      Hi, i have post one new articel at my blog.

      It looks good but I have issues

      the ….more Tag don’t work.
      when I edit an Articel the first 2 character from an word are deleted.

      When I found more I post it.

      That is the articel I have posted with this app. http://androidblogger.eu/2011/11/13/wordpress-for-android/

      Htc Desire HD

    • andrei 11:22 am on November 13, 2011 Permalink | Log in to Reply

      Well, the stats don’t work. Maybe it’s the same problem you had on 1.5.0 with rooted phones?

      • Heather 12:23 pm on November 13, 2011 Permalink | Log in to Reply

        My phone IS rooted, so that could very well be the issue.

      • Dan 8:14 pm on November 13, 2011 Permalink | Log in to Reply

        Yeah, you’re right. We used a different URL in 1.5.1 to fix that lame root issue. Added it back into the latest build that’s at the same link above, give it a go.

        • andrei 10:37 pm on November 13, 2011 Permalink | Log in to Reply

          Not working. App FCs if I tap stats. I have a Samsung Galaxy Spica with a lot of custom stuff in it, but I doubt that’s the problem.

      • andrei 10:43 pm on November 13, 2011 Permalink | Log in to Reply

        Also app FCed when I tried to add a new self-hosted blog. Curiously enough, the blog was added and seems to work.

    • Kyle Maxwell 3:21 pm on November 13, 2011 Permalink | Log in to Reply

      Force Close on a Transformer when viewing Stats and switching to Posts from Views.

    • Heather 7:19 pm on November 13, 2011 Permalink | Log in to Reply

      Tried editing a post that is scheduled for a later date, and it screwed all of the html code up. It deleted half the code I already had set. Had to redo the code from the WP site on the web.

      • Dan 8:19 pm on November 13, 2011 Permalink | Log in to Reply

        What code did it delete? Some examples would help us figure out what is happening.

        • Heather 7:47 am on November 14, 2011 Permalink | Log in to Reply

          It deleted some text formatting code (header tag, p tag), the code to center some text, and it broke down the code for a pic’s caption. It really just completely screwed up every bit of code in the post.

    • Mark 8:23 pm on November 13, 2011 Permalink | Log in to Reply

      On my Transformer, don’t seem to see images in editing mode most of the time. I’m sure i saw them there once or twice, but in most cases I see the code instead. If I’m not mistaken, I should be able to see the images and edit their settings from edit mode.

    • Paresh N Mayani 8:55 pm on November 13, 2011 Permalink | Log in to Reply

      Thanx a lot. And exciting to have new app with dashboard. Definitely post issues if any.

    • Paresh N Mayani 9:20 pm on November 13, 2011 Permalink | Log in to Reply

      Issue 1: Code is not being displayed in Source code format when we have used

    • lipilee 9:43 pm on November 13, 2011 Permalink | Log in to Reply

      awesome! however: when adding formatting using the toolbarabove thekeyboard, the html coffee its inserted but removed when saving the post

    • Sara Rosso 6:36 am on November 14, 2011 Permalink | Log in to Reply

      Photo / image issues:

      If doing New Post, I can’t add media anymore – there’s no Add Media button? Big sad face. If I want to add a photo, I know I can do Quick Photo, but what if I’ve already taken the photo and want to add it?
      Force close (replicated several times) if I select a photo from my camera’s gallery and select “Share” -> “WordPress” -> then select the blog name, then I get : “The application (proces org.wordpress.android) has stopped unexpectedly. Please try again.

      [Android Nexus S]

      • Dan 11:53 am on November 14, 2011 Permalink | Log in to Reply

        Can you install from the same link above and try the image sharing again? It should be better now. The ‘Add Media’ button was moved to the formatting bar, so you tap the content area and then the paperclip icon on the right of the bar.

        Also, I fixed the post sharing with the wp.me links, give that a try.

    • Wordpress Development 10:34 pm on November 14, 2011 Permalink | Log in to Reply

      Hey Dan, you provided really most helpful thing which is helped me so much.

    • maria 3:42 am on November 15, 2011 Permalink | Log in to Reply

      I can’t post photos. Look at this blog post and you’ll see how it turnes uout for me.. http://blogg.starweb.nu/2011/11/15/igen/ the tages are all wrong..

    • gio_n_s 8:29 am on November 15, 2011 Permalink | Log in to Reply

      not all languages (that are allready translated) are included ?
      itdoesnt have georgian language :s

      • Dan 10:14 am on November 20, 2011 Permalink | Log in to Reply

        Right, they haven’t been updated yet. I’ll get them updated this week so you can check out how it looks in Georgian.

    • Joshua Sigar 12:45 pm on November 19, 2011 Permalink | Log in to Reply

      I’ll be posting bugs in the forum because this space is getting crowded. http://android.forums.wordpress.org/forum/beta-testing

    • jonezjea 11:59 pm on November 22, 2011 Permalink | Log in to Reply

      I will test this when I am home

  • Dan 9:34 am on April 11, 2011 Permalink |
    Tags: beta   

    Any additional feedback on the 1.4 beta I… 

    Any additional feedback on the 1.4 beta? I just fixed the link helper from not working while editing a post. Post scheduling/password/http auth all seem to be pretty solid to me.

     
    • xslidian 9:38 pm on April 11, 2011 Permalink | Log in to Reply

      Please add Chinese Simp locale from http://translate.wordpress.org/projects/android/dev/zh/default ! 😀

      • Dan 7:58 am on April 12, 2011 Permalink | Log in to Reply

        Thanks! I updated the beta build with the translation, can you take a look and make sure everything is looking ok?

        • xslidian 7:54 am on April 17, 2011 Permalink | Log in to Reply

          Big Thanks!! Everything is OK except that the title inside ‘Create new on wp’ and “Blog URL:” in ‘self-hosted’ seems untranslatable…

    • Christof 2:57 am on April 12, 2011 Permalink | Log in to Reply

      Looks good to me, did not find any bugs over the last weeks (other than the fixed scheduling bug)

    • Nikki 9:42 pm on April 15, 2011 Permalink | Log in to Reply

      Hi, I’ve created a post using the WordPress android app, it says its been uploaded but how exactly do I publish it on the internet? I select share url but I receive an error post status is not published. Please help

      • Dan 11:41 pm on April 17, 2011 Permalink | Log in to Reply

        Most likely you need to change the post status from ‘Draft’ to ‘Publish’, at the bottom of the post editor and Save.

  • Dan 8:06 am on March 30, 2011 Permalink |
    Tags: beta, fixes   

    Updated/added some app translations and fixed a bug related to pages in the beta. Added a new build to try out at the same location.

     
  • Dan 6:59 am on March 10, 2011 Permalink |
    Tags: 1.4.0, beta   

    1.4.0 Beta

    We have a new build ready for beta testing! 1.4.0 adds a ton of new features and we’d love your help testing it to make sure it’s running smoothly. Changes include:

    • HTTP Authentication Support
    • Post scheduling
    • Password protected posts
    • Secure password storage
    • Unapproved comments have a yellow background
    • Minor bug fixes

    Give it a go and post any issues you find here or in trac:

    qrcode

    http://bit.ly/fuGHeb

     
    • Dan 1:36 am on March 23, 2011 Permalink | Log in to Reply

      Any issues with the beta anyone? I haven’t received any feedback…

c
Compose new post
j
Next post/Next comment
k
Previous post/Previous comment
r
Reply
e
Edit
o
Show/Hide comments
t
Go to top
l
Go to login
h
Show/Hide help
shift + esc
Cancel