If we bump up the minimum SDK to 1.6 we can build out a honeycomb app and still have compatibility for earlier versions:

http://android-developers.blogspot.com/2011/03/fragments-for-all.html